
     
 
 
 
 

 
Solveig Multimedia Video Splitter     
 
This documentation is designed to help you in using Solveig Multimedia Video Splitter. It contains information that describes basic and advanced steps for performing 
splitting tasks, description of interface items and shortcut keys. 
 
This documentation is divided into the following sections: 

●     Getting started: This section contains introductory information about Solveig Multimedia Video Splitter, supported file formats, system requirements, basic terms 
and shortcut keys 

●     Solveig Multimedia Video Splitter interface: Provides an information about controls in the Solveig Multimedia Video Splitter user interface 
●     Using Solveig Multimedia Video Splitter: Provides an information about procedures to accomplish common tasks in Solveig Multimedia Video Splitter
●     How-To: Provides an information about basic steps of video splitting process
●     Technical information: Provides a technical description of components Video Splitter is based on 
●     Version History 
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Getting started 
 
SolveigMM Video Splitter is a fast and powerful AVI, ASF, WMV video splitting tool. You can split your video file into parts in few mouse clicks without any quality loss. 
Cutting off several file portions of a movie at one time is also allowed. You can get rid of all commercials in your movie in a couple of simple steps. 
 
Since version 1.2 batch files are supported! For now you can add all the trimming tasks to batch queue and process all of them in one time. 
 
In this section: 

●     Basic terms: Explanation of concepts and terms that are referred in this document
●     Supported file formats: List of file formats that SolveigMM Video Splitter can handle 
●     System requirements: Minimum and recommended system requirements for SolveigMM Video Splitter 
●     Keyboard shortcuts: List of keyboard shortcuts 
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Basic terms 
 
This section explains key terms referred throughout this document. Understanding this terms will help you to start using Solveig Multimedia Movie Splitter in most 
comfortable way. 
 

●     Splitting process
●     Source and destination files
●     Markers
●     Fragments
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Splitting process

Splitting is a process of dividing your video files into parts. For example, you may cut off a piece of video with unlikely scenes (e.g. commercials, corrupted video). 
Splitting process leaves source files intact, saving result in destination file.
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Source and destination files 
 
 
Source and destination files are the video files of supported format. Source file contains video that you may split into parts, destination file contains final movie clip. 
During splitting process source file remains in its original location and will not be changed or deleted. 
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Markers 
 
Marker is a constituent part of a fragment to consist of two markers: start and end ones.  It is set to a current cursor position. 
 

 
 
Selected marker is depicted by a yellow color: 
 

 
 
Such operations as deleting and positioning are applied to selected markers only. 
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Fragments 
 
Fragment is a part of a movie (or audio) file limited by two markers to be removed or kept in a final movie. e.g. commercial block you need to be cut off 
Below are depicted examples of fragments:  
 

     
 

     
 
For more detailed color definition see Using splitting controls  section. 
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Supported file formats

SolveigMM Video Splitter supports media file 300037999formats as follows: 
 

- AVI file format

❍     any video content ( DivX, DV, MJPEG, XVID, MPEG-4, etc.) 
❍     any audio content (MPEG-1/2 Layer 1/2/3, Dolby AC3, PCM, OGG,  WMA, etc.) 
❍     AVI DV type1 and type2 
❍     any file size ( more than 2 GB ) 
❍     OpenDML AVI extension 

- WMV file format 

❍     any Windows Media video content (WM Video 7/9, MPEG-4 v 1/3, etc.) 
❍     any Windows Media audio content (WM audio 2/9, etc.) 
❍     non-indexed or damaged WMV files 

- ASF file format 

❍     any video content ( DivX, MJPEG, XVID, MPEG-4, WM Video 7/9, etc.) 
❍     any audio content (MPEG-1/2 Layer 1/2/3, Dolby AC3, PCM, OGG,  WMA, etc.) 
❍     non-indexed or damaged ASF files
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System requirements

Software Requirements 

●     Windows® 98/Me/2000/XP 
●     DirectX 8.0 Runtime or higher  
●     Appropriate video and audio decoders for preview feature ( DirectShow, VFW or DMO ) 
●     WMV/ASF support requires Windows Media Format 9 Series Runtime (to be shipped with Windows Media Player 9 and  higher) MS: http://www.microsoft.com/

windows/windowsmedia/9series/player.aspx 
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Hardware Requirements 

●     CPU (Intel® Pentium II, Celeron, AMD® Athlon, Opteron etc.) 
●     128 MB RAM 
●     Any VGA card 
●     About 100 MB of free disk space 
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Keyboard shortcuts 
 
Almost every procedure in SolveigMM Video Splitter can be done using shortcut keys. Using this shortcut keys you can do some tasks more quickly. 
The table below provides a list of operations that you can perform using keyboard shortcuts. 
 
 
Hot Keys of Video Splitter (main window): 
 
Operation Shortcut key
Next K frame Right arrow
Previous K frame Left arrow
Jump to 1/20th movie length forward Page Up 
Jump to 1/20th movie length backward Page Down 
Jump to movie end Home 
Jump to movie start End 
Play/Pause Space
Add Marker M 
Remove marker(s) Delete
Clear all markers Ctrl + C
Cut Off / Keep On Selected Fragment S
Invert Time Line Fragments I
Calculate destination file size (is available for AVI) Ctrl + F 

Start splitting process Ctrl + T 

Show batch manager L 
Add task to batch queue A 
Help topics F1 
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Hot Keys of Batch Manager: 
 
Operation Shortcut key

Load task list Ctrl + O 

Save task list Ctrl + S 

Add task to batch queue A 

Update task in batch queue U 

Delete selected task or fragment Delete 

Start batch processing Ctrl + T 

Edit task in main window, or show selected fragment in main window Enter
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Solveig Multimedia Video Splitter interface 

The Solveig Multimedia Video Splitter user interface consist of four main parts: Menu bar, Navigation controls, Splitter controls and Preview Window.

Main window of the program SolveigMM Video Splitter:

 

 
 
 
 
 



 
 
Batch manager window: 
 

 
 
In this section: 

●     Menu bar 
●     Navigation controls 
●     Information panel 
●     Splitting controls
●     Preview window
●     Progress window
●     Splitter in system tray
●     Filters info window 
●     Batch manager
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Menu bar 
 
You can use commands in the menu bar to perform tasks in Solveig Multimedia Video Splitter. These commands are described throughout this document. 
 
 

 
 
Menu "File" 
 

 
 
 
Menu item Description

Open media file... Allows an user to choose a supported media file to be opened and edited (*)

Save media file as... Allows an user to set an output file name an immediately save it (starts trimming process) or add to a batch queue (*), (**)

Close Close input and output file names 

Load Task List... Allows an user to load Task List to Batch Manager

Exit Close the program
(*)   - These operations are also allowed in information panel. 
(**) - To add the task to a batch queue you should set "Don't start now. Add the task to batch queue instead" check box in "Save As" dialog as depicted below: 
 



 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Menu "Edit"

 
 
 
Menu item Description Shortcut key

Next K Frame Go to the next K Frame Right arrow

Previous K Frame Go to the previous K Frame Left arrow

Jump to 1/20th forward Jump to 1/20th movie length forward Page Up

Jump to 1/20th backward Jump to 1/20th movie length backward Page Down

Stop Stop playback Space

Play Start playback Space

Pause Pause playback

Add Marker Add new marker (*) M

Cut Off / Keep On Selected Fragment Cut off or keep on selected fragment (*) S

Remove Marker(s) Remove selected marker or markers (*) Delete

Clear all marks Remove all markers  Ctrl + C

Invert Time Line Fragments Invert all time line fragments on slider (*) I

Calculate destination file size Calculate destination file size (is available for AVI) Ctrl + F

Start trimming Start trimming process (*) Ctrl + T

(*) -  These operations can be accomplished my means of menu and context menu . For  details see: Navigation controls, Information panel, Splitting controls 



 
Menu "Control"

 

Menu item Description

Obey samples times To use alternative synchronization algorithm. By default it is switched off. If resulting file is out of sync, repeated trimming this set option 
should improve audio/vido synchronization.

Video and Audio streams Allows you to choose audio and/or video streams to be rendered into final movie. For details see Using Solveig Multimedia Video Splitter.

Ignore Trimming Errors
Forces to ignore trimming errors. 
 
Note: It is reccommended to use this in switch off mode by default. 

Slider K-Frame Positioning
If this option is switched on, after positioning the slider cursor jumps to the nearest previous K Frame. This mode implements (What See Is 
What You Get) feature. 
If this option is switched off, you can navigate trhough all movie frames.

Markers K-Frame Positioning

If this option is switched on, after positioning the marker jumps to the nearest previous K Frame. This mode implements (What See Is What 
You Get) feature. 
If this option is switched off, you can set marker at any movie frame. 
 
Note: If a marker to be begin of a fragment is set to "switch off" state, the fragment in final movies will be started with K Frame anyway. 
Note: If a marker to be end of a fragment is set to "switch off" state, the fragment in final movies will end with frame at marker position.

 
 
 
 
 
 
 
 
 
 
 
 
 



Menu "Tools" 
 

 
 
 
Menu item Description

Batch Manager Contains sumbenu to Batch Manager control

Time Calculator Show time calculator

Explore Folder Opens Microsoft Exporer with a folder of Input or Output set media files.

 
Menu "Tools -> Batch Manager" 
 

 
 
 
Menu item Description Shortcut key

Show Batch Manager Shows Batch Manager window Ctrl + B

Load Task List... Allows an user to choose a supported batch file to be opened and edited 

Save Task List As... 
Allows to save Task List containin trimming task descriptions to *.xtl file. 
For Task List syntax see Batch file format

Add Task To Batch Queue Add a current task to a batch queue A

Update task Update selected task in a batch queue 

Start Batch Processing Start Batch processng

 



Menu "Help"

Menu item Description Shortcut key

Help topics... Starts the Help File F1

Keyboard ShortCuts Shows the Help File Keyboard Shortcuts section

Video Splitter on Web Allows an user to open Solveig Multimedia web pages and forum.

Register... Allows an user to register SolveigMM Video Splitter

About SolveigMM Video Splitter Shows About dialog
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Navigation controls

Navigation controls are designed for navigation through an opened source media file. By means of this controls you can start and stop the playback, pause it or seek 
for desired position forward and backward. Also current position and total duration are displayed. 
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Window item Description Shortcut key

 Button "Previous K Frame"  Right arrow

 Button "Play/Pause" Space

 Button "Stop"  

 Button "Next K Frame" Left arrow

 Edit box of a slider cursor time position. You can edit this value by manually 

 Total file length 
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Information panel
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"Input" division of Information panel shows you an input media file information such as:   
Field Description

File Source file name of the opened file

Duration Duration of the media-file, in HH:MM:SS

ByteSize Size of the source file

Video Video coding type

Audio Audio coding type

 
"Output" division of Information panel shows you an information as follows:   
Field Description

File Output file name

Size Output File Size (is available for AVI )

Selection

Selected fragment Information:  
Start Postition 
Stop Position 
Type of fragment (Cut Out/Keep On)

 
Note:  
All Information Panel values are depicted as condensed versions. To see full version value (e.g. full file name with a path) just point mouse cursor to a value and fill version will 
appear in both in Tooltip and Status bar as shown below: 
 
Note:  
All the values can be copied to a cplipboard through a context menu.  
 

     



 
Also an information panel contains "quick buttons": 
 
Button Description

 Button "Open Media File..."  

 Button "Save Media File As..."  

 
These operations are also allowed in Menu "File" 
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Splitting controls 
 
Splitting controls are the heart of Solveig Multimedia Video Splitter. Using this controls you can manage the fragments that will or will not be saved in final movie. You 
can set fragments to be cut off or  keep on, invert or completely delete fragments from your movie. Finally, the main button that starts splitting process is located in 
this panel. 
 
 

 
 
 
Window Item Description Shortcut key

 Button "Add Marker":   Adds a new marker to current slider cursor position. M

 Button "Cut Off / Keep On Selected Fragment": Sets a fragment type S

 Button "Remove Marker(s)": Removes a current marker or fragment Delete

 Button "Invert": Inverts time line fragments I

 Button "Size":  Calculate result file size (is available for AVI) Ctrl + F

 Button "Trim": Starts trimming or Batch Processing (if batch queue has any task) Ctrl + T

 Edit box of a left marker cursor time position. You can edit this value by manually 

 Edit box of a right marker cursor time position. You can edit this value by manually 

 
 
Examples of fragments: 
Fragment's color Description

 This fragment was set to be deleted. It will not be presented in final movie

 This fragment was set to be kept. It will be presented in final movie

 This fragment was set to be deleted. It will not be presented in final movie. 
Yellow highlight means you can edit it (delete, set it to be kept, etc. )

 This fragment was set to be kept. It will be presented in final movie 
Yellow highlight means you can edit it (delete, set it to be cut off, etc. )



  
 
Slider's context menu 
 

 
 
 
Menu item Description Shortcut key

Save Selected Fragment As... Allows an user to set an output file name an immediately save a selected fragment (starts trimming process) or add 
selected fragment to a batch queue (*)

Set New Marker Add new marker to the current slider cursor position M

Cut Off / Keep On Selected Fragment Sets type of selected fragment (Cut off or Keep on) S

Remove Marker(s) Remove current marker or fragment Delete

Invert Time Line Fragments Invert time line fragments I

Clear All Markers Remove all markers Ctrl + C

 
(*) - To add the task to a batch queue you should set "Don't start now. Add the task to batch queue instead" check box in "Save As" dialog as depicted below: 
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Preview window 
 
Preview window is designed for easy navigating in media file and helps you to put splitting markers as precise as possible. 
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Progress window

Progress window indicates a current progress in percents. You can cancel splitting by pressing Cancel button or hide the Splitter to System Tray by  pressing Hide 
button. 
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Below is depicted progress window of Batch Processing: 
 

 
 
Upper progress bar shows progess of the task being berformed 
Bottom progress bar shows progess of all the tasks batch queue has 
 
Hide button hides the Splitter to System Tray.  
Upon trimming finish the Splitter window appears. 
 
See also: Splitter in system tray 
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Splitter in system tray

Upon pressing Hide button, the Video Splitter is hiden to System Tray.

 

The following context menu is available when Video Splitter is in system tray:
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Menu item Description

Show Program Restore Video Splitter from system tray 

Show Progress Show current progress 

Exit Program Cancel trim process and exit 
 
Upon clicking Video Splitter system tray icon the progress information will be shown:

One trimming task:

Batch processing:
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Filters info window 
 
This window enumerates all the components that have to be presented for Video Splitter proper operating. 

1.  Press an icon of the program in the left-top corner of a window (You can use shortcut "Alt + Space") 
2.  Press "Info..."
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Batch manager window.

 

 
Batch manager window is intended for editing batch queue.  

Menu description: 

Menu "File" 

Menu item Description Shortcut key

Load Task List... Load saved batch queue from file-list (*) Ctrl + O

Save Task List As... Save batch queue into file-list Ctrl + S

Open Task List in Notepad Open batch queue in notepad (*)

Hide Close this window

(*) -  For Task List syntax see Batch file format 



 
 
Menu "Edit"  
 

 
 
 
Menu Item Description Shortcut key

Add Task To Batch Queue Add current Video Splitter task to a batch queue A

Update task Update task in batch queue in accordinance with Video Splitter changes U

Edit Task with Video Splitter Edit selected task with Video Splitter  main window Enter

Delete Selected Task(s) Delete selected task(s) Delete

Delete Selected Fragment Delete selected fragment(s) Delete

Change Selected Task(s) Out Folder Change output folder for all selected files. Program will not change result file names

Start Batch Processing Start batch processing Ctrl + T

 
 
Menu "Log"  
 

 
 
Menu Item Description

Show log Show or hide log window 

Write log file... Set file name all the messages will be written during batch manager operaing to.

Save log as... Allows an user to save all the log messages into file

Clear log Erase all messages 

 



Task queue field:

 
The list enumerates all the tasks in batch queue: 
 
Columns description: 
 
Menu Item Description

Task # Task number 

Source file Source file name 

Dest file Destination file name

Fragments count Count of fragments to be cut off 

Full time Full time of the resulting file 

Audio stream Audio stream number (*) 

Video stream Video stream number (*) 

Obey samples times To use alternative synchronization algorithm. By default it is switched off. If resulting file is out of sync, repeated trimming this set option 
should improve audio/vido synchronization. (*)

(*) - These fields can be edited in batch manager window. Just click the cell by left mouse button two times (not double click) or press scrolling mouse button. In a combo box to 
appear you can choose a necessary item as depicted below. 
 
 
Changing settings in task list window 



Conext menu description:

Menu item Description Shortcut key

Save Task List As... Save batch queue into task list file. Ctrl + S

Load Task List...
Load batch queue from  task list file  
For Task List syntax see Batch file format Ctrl + O

Start Batch Processing Start  batch processing Ctrl + T

Delete Selected Task(s) Delete selected task(s) Delete

Edit Task with Video Splitter Edit selected task in main window Enter

Select All Select all tasks

Change Selected Task(s) Out Folder Change output folder for all selected files. Program will not change result file names

Change Source File Name... 
Change Dest File Name...

Allows an user to change a source or destination file names. This point is available for "Source File" and 
"Dest file" columns only.

Copy Source File Name 
Copy Dest File Name 

Copies to a clipboard Source of Destination file name. 
This point is available for "Source File" and "Dest file" columns only.

 
 
 
 
 
 
 
 
 
 
 
 
 



Fragments list field

 
 
Here is enumerated all the fragments of selected task to be cut off. 
 
Description of Fragments list conext menu 
 

 
 
Menu item Description Shortcut key

Delete Selected Fragment Delete a selected fragment Delete

Show the Fragment in Video Splitter Shows and select the fragment in Video Splitter main window Enter
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Using Solveig Multimedia Video Splitter 
 
In this section: 

●     Opening source file
●     Using splitting controls
●     Saving media file 
●     Start trimming process
●     Work with batch queue 
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Opening source file. 

File operations in Solveig Multimedia Video Splitter are performed via Menu bar.

To open source file go to Menu bar, select File -> Open Media File... Select your video file in standard open file dialog. This file will not be changed, deleted or 
moved during splitting process.

To set destination file, select File -> Output File... and give a name to the destination file. If file with the same name is already exists, you will be asked for replacing the 
old file with the new one. You can overwrite the old file or give a new file name to the destination file.

See also: Menu "File", Information panel 
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Using splitting controls

Before trimming start you should define  fragments you want to be cutt of or keep on in resulting file. 

To add a new fragment to slider: 

1.  Navigate to the beginning of a future fragment
2.  Press Set new marker button (M), or choose Edit -> Set New Marker menu item from Menu bar
3.  Navigate to the ending of the future fragment
4.  Repeat step 2
5.  Set fragment type by Edit -> Cut OFF / Keep On Selected Fragment (S)
6.  If you need to change start or stop fragment positions just drag markers to new positions         

  

 
Examples of fragments: 
Fragment's color Description

 This fragment was set to be deleted. It will not be presented in final movie

 This fragment was set to be kept. It will be presented in final movie

 This fragment was set to be deleted. It will not be presented in final movie. 
Yellow highlight means you can edit it (delete, set it to be kept, etc. )

 This fragment was set to be kept. It will be presented in final movie 
Yellow highlight means you can edit it (delete, set it to be cut off, etc. )

 
 
 
 
 
 
 
 
 
 
 
 
 
 



   
Window element Description Shortcut key

 Button "Add Marker":   Adds a new marker to current slider cursor position. M

 Button "Cut Off / Keep On Selected Fragment": Sets a fragment type S

 Button "Remove Marker(s)": Removes a current marker or fragment Delete

 Button "Invert": Inverts time line fragments I

 Button "Size":  Calculate result file size (is available for AVI) Ctrl + F

 Button "Trim": Starts trimming or Batch Processing (if batch queue has any task) Ctrl + T

 Edit box of a left marker cursor time position. You can edit this value by manually 

 Edit box of a right marker cursor time position. You can edit this value by manually 

 
 

© 2005-2006 Solveig Multimedia. All rights reserved. 

 
Start trimming process. 
 
 
To start trimming process, after you set all the fragment you want to be deleted/saved, call File -> Save Media File As... (for details see Menu "file") or Save 
Media File As.. "quick button" (for details see Information panel ) or push "Trim" button (for details see Splitting controls ) 
 
Note: You can save (trim) any selected fragment by means of a slider context menu Save Selected Fragment  As.. point (for details see Splitting controls) 
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Working with batch queue. 
 
To create a new batch queue (task list):  

1.  Open a media file you want to edit, set all the fragments you want to be saved/removed. For details see Opening source file and Solveig Multimedia Video Splitter interface
2.  Add the task to queue. For this call menu Tools -> Batch Manager -> Add Task To Batch Queue
3.  Repeat 1 and 2 points for all the files you want to process.

See also:  Menu "Tools", Keyboard shortcuts 
 
 
Also you can add the task to queue by calling menu File -> Save Media File As..., or Information panel quick button, or Save selected fragment as.. slider context menu (for 
detail see Splitting controls). You should set "Don't start now. Add the task to batch queue instead" check box as it is depicted below: 
 
 

 
 



 
To open Batch Manager window call menu Tools -> Batch Manager -> Show Batch Manager or Tools -> Batch Manager -> Load Task List... to open task 
list file. 
Batch Manager window allows you to change audio/video streams, "Obey samples times" attribute, delete any fragments, etc. For details see Tasks queue field. 
To edit the task you have to open it within Video Splitter, change fragments or settings, and update: 
 

1.  Select the task you need to be changed. Call menu Edit -> Edit Task with Video Splitter or Edit Task with Video Splitter of context menu or press Enter hot key. For 
details see Tasks queue field,  Keyboard shortcuts

2.  Change the task within Video Splitter main window. To view existing fragments in Video Splitter you can use Fragments list field. For this call  Show the Fragment in 
Video Splitter of context menu, or press  Enter hot key. For details see Keyboard shortcuts 

3.  After changing trimming settings in Video Splitter update the task in batch queue by calling  Tools -> Batch Manager -> Update Task or menu  Edit -> 
Update Task  of Batch Manager window.
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How-to. 
 

●     register Solveig Multimedia Video Splitter
●     open video file
●     preview video clip
●     navigate in your video
●     set and delete markers
●     set fragments to be kept or delete
●     select video and audio streams
●     fix audio/video synchronization 
●     start splitting
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How-to register Solveig Multimedia Video Splitter 
 
To register Solveig Multimedia Video Splitter please do the following: 
 
1. Go to the Menu bar, choose Help -> Register. Registrator window will appear 

         
     
2. Select "SolveigMM Video Splitter" from the list.  

         
 
3. If you already have serial number skip to step 4 else press "Buy Now" button. Web browser will bring you to 'Buy product' page. Please, follow the instructions on screen.  
 
4. Press "Activate" button and enter your serial number, then press OK button 

 
 
5. Registration completed!  
 
Note: Registrator window will appear during evaluation period at every application launch. Registrator window will appear at application launch, application exit and in 
the beginning of splitting process after expiration of evaluation period. 
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How-to open video file 
 
To open your video file you intended to split, do the following: 

1.  Go to the Menu bar, choose File -> Open Media File..., standard Windows open file dialog will appear. 
2.  Locate your video file and press Open. 

 

 
 
See also  Supported file formats, Menu "File" 
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How-to preview video clip 

1.  Open video file 
2.  To start playback press Play button. Also you can use Edit -> Play menu command or use shortcut key (Space) 
3.  To pause playback press Pause button. You can use Edit -> Pause menu command or shortcut key (Space) respectively 
4.  To stop playback press Stop button or choose Edit -> Stop from Menu bar.

 
Window element Description Shortcut key

 Button "Previous K Frame" Left arrow

Button "Next K Frame" Right arrow

 Button "Play/Pause" Space

 Button "Stop" 

 
See also: Navigation controls, Menu "Edit", Keyboard shortcuts 
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How-to navigate in your video 

1.  To advance to the next K frame press Next K Frame button, or choose Edit -> Next K Frame menu item from Menu bar. You can use shortcut key (Right arrow) also. 
2.  To change the position to the previous K frame, press Previous K Frame button, or choose Edit -> Previous K Frame menu item. Shortcut key (Left arrow) also 

available. 
3.  Left click mouse on the timeline at desired position. 
4.  Type in desired time into edit box in Navigation controls in HH:MM:SS.mS format. Position will be automatically adjusted to the nearest previous K frame. 

Note: You can switch off K frame positioning both to slider cursor and markers by calling menu Control -> Slider K-Frame Positioning è Ñontrol -> Marker K-
Frame Positioning. Buttons Next K Frame è Previous K Frame, start go to nexx and previous frames (not K frames). 
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Windows element Description Shortcut key

 Button "Previous K Frame" Left arrow

 Button "Next K Frame" Right arrow

See also: Navigation controls, Menu "Edit", Menu "Control", Keyboard shortcuts 

© 2005-2006 Solveig Multimedia. All rights reserved. 

 
How-to set and delete markers 

To set a new marker do the following:

1.  Navigate to the desired position 
2.  Press Set new marker button (M), or choose Edit -> Set New Marker menu item from Menu bar 

To delete a marker:

1.  Left click the marker you want to delete. 
2.  Press Remove marker/fragment button (Delete), or choose Edit -> Remove marker or markers menu item from Menu bar 

To delete all markers from timeline select Edit -> Clear All Marks menu item from Menu bar, or use Ctrl + C shortcut

Note: markers will be deleted without any confirmation

 
Window element Description Shortcut key

 Button "Add Marker" M

 Button "Remove Marker(s)" Delete

 
 
See also: Menu "Edit", Keyboard shortcuts, Splitting controls 
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How-to set fragments to be kept or deleted 
 
To define a new fragment: 

1.  Navigate to the beginning of future fragment 
2.  Press Set new marker button (Ctrl + M), or choose Edit -> Set New Marker menu item from Menu bar 
3.  Navigate to the ending of the future fragment 
4.  Repeat step 2 

To adjust fragment start and stop times:

1.  Select marker at the beginning/ending of the fragment 
2.  Drag marker to the desired position (or use Next K Frame/Previous K Frame buttons) 

To delete a fragment:

1.  Left click the fragment you want to delete. 
2.  Press Remove marker/fragment button (Delete), or choose Edit -> Remove marker or markers menu item from Menu bar 

Note: fragment will be deleted without any confirmation.

To set fragment to be kept or deleted: 

1.  Left click the fragment you want to be kept or deleted. 
2.  Press Cut Off/Keep On Selected Fragment button ( S), or choose Edit -> Cut Off/Keep On Selected Fragmen menu item from Menu bar

Window element Description Shortcut key

 Button "Add Marker" M

 Button "Cut Off / Keep On Selected Fragment" S

 Button "Remove Marker(s)" I

 
 
See also: Menu "Edit", Keyboard shortcuts, Splitting contros  
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How-to select video and audio streams 
 
 
Solveig Multimedia Video Splitter allows you to choose audio and video streams that will be rendered into the final movie. To choose streams open menu "Control": 
 

 
 
In lower part of menu is enumerated all the video/audio streams input media file contains. 
Choose streams you want to be presented in output file. 
 
In depicted example only audio stream will be saved. 
 
See Also:  Menu "Control" 
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How-to fix audio/video synchronization 
 
 
Solveig Multimedia Video Splitter is designed to split media files without loosing audio/video synchronization. However some media files are loosing synchronization 
after splitting. To avoid loosing sync, you may try to do the following: 
 

1.  Open your video file 
2.  Define fragments you want to keep in final movie. 
3.  Go to Menu bar and check Control -> Obey Sample times menu item. 
4.  Continue splitting process as usual. 

See Also:  Menu "Control", How-to set fragments to be kept or deleted 
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How-to start splitting 
 
To start trimming process you need to: 

1.  Open your video file 
2.  Define fragments you want to keep in final movie 
3.  Press Trim button (Ctrl + T), or select Edit -> Start Trimming 
4.  If you will be asked for file name, enter a file name for destination file and press Save. Progress bar will appear, indicating that splitting is in progress. 

Note:  Calling menu File -> Save Media File As... also starts trimming process. 
Note:  Instead of immediate trimming you can add task to a batch queue by setting "Don't start now. Add the task to batch queue instead" check box, as it is 
depicted below:

 
 
 



Window element Description Shortcut key

 Button "Trim": Start trimming process Ctrl + T

 
See also:  Menu "Edit", Keyboard shortcuts, Splitting controls, Batch manager 
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Technical information 
 
 
Video splitter was designed based on SolveigMM Video Editing SDK.  
AVI Trimmer Component is the freeware demonstration of the SDK. Concerning SolveigMM Video Editing SDK please contact the Solveig Multimedia Technical Support 
Team: support@solveigmm.com

SolveigMM Video Splitter includes the following components: 

Component File Name Description

SolveigMM AVI Trimmer AVITrimmer.ax

DirectShow filter providing GOP accurate 
video/audio trimming operations for AVI 
and ASF formats.

SolveigMM AVI File Writer AVI_Writer.ax
DirectShow filter intended for keeping A/V 
synchronization during AVI trimming with 
MPEG L3 VBR audio.

SolveigMM K Frame Manager KeyFrameManager.ax DirectShow filter providing K-Frame 
navigation

SolveigMM ASF Multiplexer SMMASF.ax DirectShow filter providing A/V 
multiplexing to ASF container format. 

SolveigMM Video Editing Engine aka SolveigMM AVI 
Trimmer COM Object AVITrimmerCOM.dll

COM object that allows video editing 
according to the user interface prepared 
script.
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Batch file structure.

 
Batch files Video Splitter supports have extension - *.xtl and based on DirectShow Editing Services XTL format.  
 
Note: All the sections and attributes are sensitive to keyboard case and  must be in  lower case. The values must be quoted (""). 
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timeline Element

The timeline element defines the timeline. This element is the root node in the XML file. 

Example: 
<timeline> 
</timeline> 
 
Attributes: 
no attributes specified. 
 
Parent/Child Information 
Parent Children 

No, this is root element. group

 
 
group Element 

The group element defines a group, the top-level object in a timeline. 

Example: 
<group name="....."> 
</group> 
 
Attributes: 
Attribute name Possible values Must present? Description

name Any string without symbol (") Yes The name attribute specifies output file 
name with path 

 
Parent/Child Information 
Parent Children

timeline track

 
track Element 

The track element defines a track object (media files ).

Example: 
<track video="..." audio="..." obey_sample_times="..."> 
</track> 
 
 
 



Attributes: 

Attribute name Possible values Must 
present? Description

video any number No The video attribute specifies number of video stream. 0 value 
means the output file has not to contain a video stream  

audio any number No The audio attribute specifies number of audio stream. 0 value 
means the output file has not to contain an audio stream

obey_sample_time 0, 1 No

The obey_sample_times attribute specifies to use alternative 
synchronization algorithm:  
 
0 = Don't use obey_sample_time 
1 = Use obey_sample_time

 
Note: 
By default if neither video nor audio is specified both of them equal 1; if one of the values presents - default value of missed parameter is 0;  
by default  obey_sample_time  equals 0. 
 
Parent/Child Information 
Parent Children

group clip

 
 
clip Element 

The clip specifies a media source. 

Example:  
<clip src="..." start="..." stop="..." /> 
 
 
 
Attributes: 

Attribute name Possible values Must 
present? Description

src any string without symbol (") Yes The src attribute specifies the path name of an input media file 

start HH:MM:SS.mS Yes The src attribute specifies start time of a fragment to be saved in 
output file. 

stop HH:MM:SS.mS Yes The src attribute specifies stop time of a fragment to be saved in 
output file. 

 
Note: 
Within track section values of  src attributes of all clip sections  must be identical. 
 



 
Parent/Child Information 
Parent Children

track no

 
 
Batch file example

<timeline> 
    <group name="C:\video\result\Noname.avi"> 
        <track video="1" audio="2" obey_sample_times="0"> 
 
            <clip src="C:\video\Progulka.avi"  start="00:00:00.00"    stop="00:12:32.00" /> 
            <clip src="C:\video\Progulka.avi"  start="00:32:41.00"    stop="00:42:02.00" /> 
            <clip src="C:\video\Progulka.avi"  start="00:54:09.00"    stop="01:08:51.00" /> 
 
        </track> 
    </group> 
    <group name="C:\video\result\Noname1.avi"> 
        <track video="0" audio="1" obey_sample_times="1"> 
 
            <clip src="C:\video\Microcosmos.avi"  start="00:11:48.08"    stop="00:20:14.52" /> 
 
        </track> 
    </group> 
</timeline> 
 
As result there should be created two files: 

1) C:\video\result\Noname.avi - the file have to consist of three sequential fragments from C:\video\Progulka.avi

Start time End time

00:00:00.00 00:12:32.00

00:32:41.00 00:42:02.00

00:54:09.00 01:08:51.00

   The file will contain video stream and second of two audio stream to be contained in input media file.



2) C:\video\result\Noname1.avi - the file have to consist of one audio fragment from C:\video\Microcosmos.avi 

Start time End time

00:11:48.08 00:20:14.52

 
 The file will contain only audio stream.
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Version History 
 
 

Solveig Multimedia products version history: 
 
 
SolveigMM Video Splitter 
 
 
Version 1.2.7.15 update  Release Date: July 15,  2006 
Fixes: 

●     The bug with Unicode file names e.g. with Chinese or Japanese symbols was fixed. Video Splitter was unable to open/same such files.
●     The bug with opening/playing WMV files by Windows Media Player was fixed. After opening, WMP  didn’t start playing of WMV files produced by Video 

Splitter.
●     The ASF files produced by Beholder TV Tuner was fixed. Video Splitter was unable to edit ASF files (DivX + PCM) captured within Beholder TV Tuner.
●     Some more bugs with WMV video/audio trimming precise were fixed

 
Features: 

●     Some Menu, Context Menu and Batch Manager changes were made for GUI simplification.
●     "Menu->Output File Name.." was changed to "Save Media File As..". This menu point sets out file name and either starts trimming or add task to batch queue.
●     "Context Menu->Save Selected Fragment As..." point was added.  This point operates like "Menu->Output File Name.." but with one fragment only. 
●     "Invert Time Line Fragments" command automatically adds additional markers if it is necessary.
●     For now you can switch off "Markers K Frame Positioning" and "Slider K Frame Positioning"
●     Ignoring Trimming Errors" feature was added. (It's used when WM/ASF Reader delivers error "the buffer is not big enough").
●     All the features including Task List (batch) file format is documented.

 
Version 1.2.6.15 update  Release Date: June 15,  2006 
Fixes: 

●     The bug with WMV navigating was fixed (with some WMV files a navigation din not operate)

Version 1.2 beta              Release Date: June 13,  2006 
Features: 

●     Batch files processing (trimming, saving/opening list file)
●     Audio stream choosing ability was added (before, the first audio stream was trimmed )



 
Fixes: 

●     The bug with WMV last frame was fixed (often last video frame of WMV was not rendered)
●     The bug with WMA inaccuracy was fixed 
●     Some trimming bugs concerning inaccuracy and video artifacts were fixed

 
Restrictions: 

●     Batch files  processing is not documented for the present

 
 
Version 1.1.5.10 update  Release Date: May 10,  2006 
Fixes: 

●     The bug with one of AVI streams splitting has been fixed ( if AVI had only one stream: video or audio, or a user selected only one stream to be trimmed the 
Splitter didn’t operate )

●     The bug with audio only of WMV/ASF splitting has been fixed ( if a user selected audio stream to be trimmed the Splitter didn’t operate )
●     The bug with audio AVI to ASF conversation has been fixed ( if a user selected audio stream to be trimmed to ASF file the Splitter didn’t operate )

 
Enhanced: 

●     Positioning feature has been added. Now upon double-click to a marker, the slider jumps to a marker position 

Version 1.1.5.02 release  Release Date: May 02,  2006 
Enhanced: 

●     Buttons "Open file" and "Output File" have been added for usability to "Movie" and "Selection" sections
●     Feature to "Index" or "Remux with indexing" for  unindexed or damaged  ASF and WMV  files has been added
●     Time Edit Boxes for markers and fragments are enabled to manual editing
●     "Copy/Paste" feature has been added to time edit boxes of slider and markers
●     Jumping to 1/20th of movie length forward and backward (Page Up, Page Down) and to a movie start/end positions (End, Home) has been added

 
 
 
 
 



 
 
Fixes: 

●     The bug with AVI damaging while trimming has been fixed (after trimming in lower part of video in some AVI files appeared artifacts)
●     The bug with a last frame in timeline has been fixed (neither markers nor slider were allowed to be set to last frame)
●     The bug with redrawing a video frame while dragging the Video Splitter in overlay mode has been fixed (now a frame is redrawn after dragging stops)
●     The bug with filters enumerating in "icon"->"info" dialog has been fixed

 
 
Version 1.1.3.24 beta  Release Date: Mach 23,  2006 
Enhanced: 

●     Formatting  "Byte Size" value has been added for usability (e.g. old value sight 1461925888 and new one is 1 461 925 888 )

 
Fixes: 

●     The bug with hanging after trimming completes has been fixed
●     The bug with big DV files more than 7 minutes (slider time repeating) has been fixed
●     The bug with estimating output AVI file size ( getting size process was not started) has been fixed
●     The bug with trimming raw video AVI (e.g. RGB24 ) has been fixed

 
 
Version 1.1 beta        Release Date: December 20,  2006 
Features: 

●     Supports WMV  format
●     Supports ASF file format with any video (WMV 1,2,3,  MPEG-4 AVC, DivX, etc) and audio (MPEG L. 1,2,3, AC3, WMAudio V 2,7,8, etc) content 
●     AVI to ASF re-multiplexing (without re-encoding)

 
Fixes: 

●     The bug with AVI contained MPEG1 layer 2 audio has been fixed
●     The bug with Help calling has been fixed

 
 
 



 
Changes: 

●     SolveigMM ASF Multiplexer has been added to package

 
Restrictions: 

●     "Size" feature does not operate within WMV/ASF mode, and it is not documented for the present
●     WMV/ASF support  is not documented for the present

 
Note: 
WMV/ASF  supporting requires Windows Media Format 9 Series Runtime (to be shipped with Windows Media Player 9 and  higher) 
    MS: http://www.microsoft.com/windows/windowsmedia/9series/player.aspx 
    Dptop Link: http://www.dptop.com/app/wmfdist9.exe (5 MB) 
 
 
Version 1.0.3.13        Release Date: December 28,  2005 
Enhanced: 

●     A feature of getting output AVI file size  has been added

 
Version 1.0.2.1          Release Date: October 30,  2005 
Fixes: 

●     The bug with messed control colors when Video Card bit depth is 24 or 8 bits has been fixed.

 
Changes: 

●     To avoid registration problems with COM components the following system DLLs have been added to installation:    atl71.dll,  msvcp71.dll,  msvcr71.dll

 
Version 1.0 release    Release Date: September 24,  2005 
Enhanced: 

●     An input AVI file Drug and Drop feature  has been added
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Fixes: 

●     K frame navigation has been improved
●     DV AVI type 1,2 preview has been added
●     The bug when an initial output file was overwritten during a second trimming operation has been fixed.
●     WYSIWYG feature ( i.e. precision ) has been improved
●     Some issues with out of sync on some kind of AVI files  have been fixed

 
Changes: 

●     An ability to register the version has been added
●     An ability to view the filters info has been added

Known problems: 
- Navigation problems with DivX decoders 
 
Version 1.0 beta    Release Date: August 12, 2005 
Features: 

●     Based on a freeware SolveigMM AVI Trimmer Component
●     Supports any AVI file format (DV type 1 and 2, OpenDML) with any video (DivX, XviD, 3ivX, etc.) and audio (MPEG-1, MPEG-2 layer 3, AC3, etc.) content. 
●     Supports large AVI files (more than 2GB) 
●     Allows trimming AVI files contained VBR audio without synchronization loss 
●     Advanced K frame navigation 
●     K frame accuracy 
●     WYSIWYG preview 
●     Allows multiple fragment processing in single pass 
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